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Preface

This course is designed to teach you the most important commands and tools for 3D drawing
step by step, so as to introduce you to drawing with Vectorworks. To complete this class
successfully, you should be familiar with Vectorworks’ user interface and the basic tools and
commands.

Goals

In this course, you will...

...draw a counter using 2D and 3D tools.

...become acquainted with different view and visualization methods.

...learn how to create sheet layers and viewports.

...create a rendering of your drawing.

Requirements

This tutorial is based on Vectorworks interiorcad 2009 including Renderworks 2009. 

You should have a standard installation on your computer.

We recommend a screen resolution of 1280 x 1024 pixels or more.

If possible, use a wheel mouse.

You should have basic knowledge of your operating system, know the names of the keys
on the keyboard (e.g. Ctrl, Alt, etc.) and have basic Vectorworks skills.
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1 Preparations

1.1 Downloading the Template

To start the exercise, download the template Template Counter Design.sta and a halftone
image needed for the exercise from “www.extragroup.de/learning” and copy them to your
computer.

Download the installer for Windows or MacOS respectively and save it to the desktop.

Double-click the installer file and follow the instructions in the dialogs. (MacOS: Unzip the
archive and put the file Vorgabe Thekenplanung.sta into the folder Templates, which is
located in the Vectorworks program folder.)

1.2 Opening the Template

Now you can start Vectorworks and open the template. 

1 Choose File > New...

2 In the pop-up dialog, select Use Document Template.

3 Select Template Counter Design.sta from the pull-down menu.

4 Click OK to confirm.

5 Choose File > Save as... and save the file as „Counter Design.vwx“.

Make sure to save your drawing every now and then using Ctrl+S. You can also choose
File > Save.
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1.3 Vectorworks Interface

If you have trouble finding a button or palette during the course, simply refer to this page.

The workspace used here is called interiorcad. If your screen looks different, you can select
this workspace from Tools > Workspaces.

All frequently used 2D tools are in the Basic palette to the left of the drawing. All other tools
can be selected from the Tool Sets palette on the very left. Use the buttons in the bottom left
corner to toggle between tool sets.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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1.4 Vectorworks Preferences

It is recommended to check some of the most important basic preferences in order to guar-
antee that they match those used in this tutorial.

1 Select Tools > Options > Vectorworks Preferences….

2 In the Display tab, select Only in wireframe from the Display light objects pull-down
menu.

3 On the Session tab, set the Maximum number of undos to 40.

4 We also recommend adjusting the settings on the Autosave tab as shown below.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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2 Drawing the Counter

Open the template. A floor plan appears in the drawing:

The end result is the counter shown below:
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In this chapter, you will become acquainted with the following tools and commands:

Set 2D locus 

Draw Arc  

Split 

Create NURBS curve (Ctrl+Alt+N)

Create Tapered Extrude (Ctrl+Alt+U)

Flyover 

Create Shell Solid 

Assign textures

Change Render mode

Extract 

Move 3D (Ctrl+Alt+M)

Extrude Along Path 

Create Contours 

Group and Ungroup objects

Compose contours
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2.1 Plinth

The first step is drawing the counter’s plinth.
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2.1.1 Set 2D Locus

We set a 2D locus to define the center of the arc.

1 Select the 2D Locus  tool from the Basic palette.

2 Without clicking, move the cursor to the corner indicated below and then upwards. An
extension line and the cue Align H will appear.

The extension line disappears. 

3 Slowly drag the cursor to the right. 

A new extension line appears. 

4 When you reach the first extension line, Vectorworks displays both lines, aligns the first
and second points, and displays the cue Intersection. 

Please do not click the mouse again until we reach step 6. Simply move the cursor as
described. 
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5 Left-click once to set the 2D locus.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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2.1.2 Draw an Arc

In the next step, we draw an arc from the bottom edge of the column to the right wall.

1 Select the Arc  tool from the Basic palette.

2 Select Arc by Radius Mode on the Tool bar.

3 Click the 2D locus once to place the center of the arc.

4 Move the cursor to the bottom left corner of the column. 

The column’s edges are 250 mm long. Since we want the arc to start in the center of the
column’s edge, we have to add 125 mm to the radius. 

5 Press TAB to access the Data bar, enter 1705+125 into the L field and press Enter.

Vectorworks adds the values. Now the radius cannot be changed anymore.

6 Click the edge of the column.

7 Click the right wall of the room (cue: Vertical) to place the end point of the arc.
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The arc is created as shown below:

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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2.1.3 Split Arc

The three parts of the counter are offset from each other by 50 mm. To create this effect, we
split the arc into three parts and change the radii of the parts. 

1 Make sure that the arc is selected. 

2 Select the Split  tool from the Basic palette and select Line Split Mode on the Tool bar. 

3 Click the 2D locus created in chapter 2.1.1 (center of the arc) (Click #1) and drag the
cursor to the left beyond the arc.

4 Press TAB repeatedly until the Angle input box is marked. Enter -155 degrees and press
Enter to confirm.

5 Press Alt (!) while clicking again outside the arc (Click #2).

6 Repeat the last step to create the third arc. Enter -117 degrees.

It is vital that you press Alt during the second click to make sure that only selected
objects are split. Otherwise all objects along and beyond the split line are split as well.

Click #1

Alt+Click #2
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Now we extend the radii of the arcs in the center and on the right.

7 Select only the arc in the center and use the Object Info palette to add 50 mm to the
radius.

8 Press Enter to confirm.

9 Repeat the previous two steps to add 100 mm to the radius of the arc on the right.

Now the arcs should look like this:

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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2.1.4 Create NURBS Curves

In the next step, we will draw connections between the arcs and add depth and height to the
plinth. As you can see in the drawing, the arcs have a surface. Giving those a height would
result in objects shaped like slices of cake. Since we only need the rounded edge of the arc to
create the plinth, we first convert the arcs to NURBS curves (3D curves).

1 Select one of the arcs and press Ctrl+Alt+N.

The Object Info palette shows that the selected object is a NURBS Curve.

2 Repeat for the other two arcs.

2.1.5 Flyover

We can now look at the intermediate result in 3D.

1 Press Shift+C to select the Flyover  tool. (You can also select the tool from the Basic
palette.)

2 Click an end vertex of one of the NURBS curves.

The cursor turns into a dashed cross.

3 Hold down the left mouse key to rotate the drawing around this vertex.

2.1.6 Create Tapered Extrude

Now we can convert the arcs to 3D objects.

1 Select one of the arcs and press Ctrl+Alt+U. (You can also choose Model > Tapered
Extrude...)

2 Enter 120 mm into the Height (Z) input box. Make sure that the Taper Angle is set to 0.
Click OK to confirm..

3 Create tapered extrudes with a height of 120 mm from the remaining NURBS curves as
well.
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2.1.7 Create Shell Solid

We now use the Shell Solid  tool to add depth to the surface elements.

1 Select the Shell Solid  tool from the 3D Modeling tool set and click Shell Solid Prefe-
rences  in the Tool bar.

2 Enter 19 mm in the Thickness box.

3 Select Inside in the Shell area.

4 Click OK to confirm and click one of the tapered extrudes.

The extrude is marked in red. 

5 Click the green checkmark in the Tool bar or press Enter to confirm.. 

6 Repeat for the other extrudes.

2.1.8 Draw Connections

In the next step, we will draw connections between the plinth elements.
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1 Press Ctrl+5 to change to Top/Plan view .

2 Select the Double Line  tool from the Basic palette.

3 Make sure that Top Control Line Mode and Unconstrained Double Line Mode are
selected on the Tool bar.

4 Click Double Line Preferences . 

5 Enter 19 mm in the Separation box and select Create Polygons.

6 Click OK to confirm.

7 Click the corner of the central arc as indicated below (Click #1).

8 Press TAB to access the Data bar, enter 180 mm for L and press Enter to confirm.

Click #1
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9 Click the 2D locus (center of the arcs) to align the double line (Click #2).

10Repeat for the second connection. The double lines have to be 270 mm long this time.

We redouble this connection with another element.

11For this second element, we change to Bottom Control Line Mode.

Click #2
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12Start the double line at the inner right corner of the central arc (Click #1).

13The double line should be level with the existing element (Click #2).

Now we also give those connections a height.

1 Select one of the double lines created in the last step (Object Info palette: Polygon).

2 Press Ctrl+E and enter 120 mm in the Height (Z) box.

3 Repeat for the remaining two connections.

The finished plinth should now look like this

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Click #1

Click #2
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2.1.9 Group Plinth

Next, we group all parts of the plinth for more clarity.

1 Press X to change to the 2D Selection tool. Press Shift and select all parts of the plinth.

The Object Info palette shows that 6 Objects are selected.

2 Press Ctrl+G.

The message in the Object Info palette changes to Group.

2.1.10 Assign Texture

Finally, we assign the plinth a texture for photo-realistic rendering.

1 Select the plinth.

2 Click the Home button  in the Resource Browser to make sure that the Resource
Browser displays the resources of the file “Counter Design” 

3 Scroll down until the category “Textures” is visible.

4 Double-click the texture Metal Aluminium 02 MAT.

Now, you can only select the plinth as a group. Any changes to the plinth have to be
made inside the group. To access it, double-click the group. Depending on your Vectorworks
settings, only the plinth will be displayed in the drawing or all other parts of your drawing
are displayed grayed. The separate elements can be selected individually. Click the orange
Exit Group button in the top right corner to return to the drawing.

If the Resource Browser is too narrow in your workspace, move the mouse over the left
edge of the Resource Browser. When the cursor changes to this shape , you can click
and drag the edge to the left while holding the mouse. You can drag it back as desired in
the same way.
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2.1.11 Change Render Mode

Now you can define a 3D view to look at a rendering of the plinth.

1 Press Ctrl+5 to change to Top/Plan view.

2 Choose View > Set 3D View.

3 Use the mouse wheel to zoom out until the whole room is displayed.

4 As shown below, first click to define the viewpoint (Click #1) and then to define the direc-
tion (Click #2).

5 Set Viewer Height to 1500 mm, Look Toward Height to 500 mm and Perspective to
Normal.

6 Click OK to confirm.

A perspective view is displayed in the drawing.

Click #1

Click #2
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We will now edit the Render mode preferences.

1 Select Current Render Mode in the View bar. Then click Options For Other Render
Modes...> (!) and select Custom Renderworks Options...

2 Make sure that the settings are adjusted as displayed below and click OK to confirm.:

All 3D views can be saved and accessed at a later point: Click Saved Views in the View
bar. Refer to the manuals for further details.

If the Current Render Mode box is not displayed in the View bar, make the Resource
Browser or other palettes (cursor ) a bit narrower.
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3 Select Current Render Modes again and click Custom Renderworks. 

4 Change back to Wireframe to continue the exercise.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Use the dialog Custom Renderworks Preferences to adjust the quality of the rende-
rings. Final Quality Renderworks offers the best visualization results, but it also uses more
computing time and resources than any of the other visualizations.

Depending on the size of the project and the speed of your computer, it may take the
program some time to render the drawing. A progress bar will appear in the Tool bar during
rendering. You can press Esc at any time to abort rendering.

It is important that you always draw using the Wireframe Render Mode. Otherwise,
Vectorworks renders the complete drawing after every change you make.
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2.2 Front Scribes

In this step, we will draw front scribes for the counter.

2.2.1 Extract Front Scribe Edges

The front scribes all have a radius that is 19 mm longer than that of the plinth. We extract
the outer edge of the plinth parts and add 19 mm to the radius.

1 Select View > Projection > Orthogonal.

2 Zoom in on the peft part of the plinth.

In chapter 2.1.9, we grouped the plinth parts. Now we want to work inside this group.

3 Double-click one of the plinth parts to get inside the group.

4 Select the Extract  tool from the 3D Modeling tool set.

5 Select Extract Curve Mode in the Tool bar.
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6 Click the bottom front edge of the plinth part.

The edge is marked in red.

7 Press Enter or click the green checkbox in the Tool bar.

The edge is displayed as a thin NURBS curve and marked in red.

2.2.2 3D Move Curve

The bottom edge of the front scribe is to start 100 mm above the ground, so we move the
NURBS curve to the appropriate height.

1 Make sure that the NURBS curve just created is selected.

2 Press Ctrl+Alt+M to call 3D Move... (You can also choose Modify > Move > Move 3D... or
select it from the contextual menu.)

3 In the following dialog, enter 100 mm in the Z Offset box. Make sure that X Offset and Y
Offset are set to 0. Click OK to confirm..
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2.2.3 Height and Wall Thickness of Scribes

We use Tapered Extrude to create the height of the scribes.

1 Press Ctrl+Alt+U. (You can also choose Model > Tapered Extrude.)

2 Enter 1300 in the Height (Z) box and make sure that the Taper Angle  is set to 0 degree.

3 Click OK to confirm.

Now we make the scribe 19 mm thick.

1 Select the Shell Solid  tool from the 3D Modeling tool set and click Shell Solid Prefe-
rences  in the Tool bar. 

2 Set Thickness to 19 mm.

3 Select Outside (!) in the Shell area. 

4 Click OK to confirm. Then click the edge of the tapered extrude so it is marked in red.

5 Press Enter or click the green checkmark in the Tool bar.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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The first scribe should now look like this:

6 Repeat the steps described in chapters 2.2.1 to 2.2.3 for the other scribes, but give the
central scribe a height of 1000 mm and the right one a height of 1100 mm.

The result should look like this:
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2.2.4 Bevel Top Edge

In the next step, the top right corner of the left scribe is to be beveled.

1 Select the 3D Selection  tool from the 3D Modeling tool set and select the left scribe.

2 Change to Left View via the Views palette or in the Current View menu in the View bar.

3 Select the Split  tool from the Basic palette.

4 Select Line Trim Mode in the Tool Bar. 

5 The cut is to begin at the top left corner (Click #1). 

6 Press TAB repeatedly until the A box is marked. Enter -17 degrees and press Enter to
confirm.

7 Move the cursor beyond the right edge of the scribe and click (Click #2).

An arrow appears at the edge of the split, indicating which side is to remain after the cut.

8 Press Alt (!) and click below the split line (Click #3).

2.2.5 Panels Between the Scribes

In the next step, we create the side panels between the scribes.

1 Press Ctrl+5 to return to Top/Plan view and zoom in on the left connection of the plinth.

2 Select the Double Line  tool from the Basic palette.

3 Select Top Control Line Mode and Unconstrained Double Line Mode in the Tool bar.

Click #2

Click #1

Alt+Click #3
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4 Click Double Line Preferences . Check that Separation is set at 19 mm and that Create
Polygons is selected.

5 Now draw a double line from the inner left corner of the central scribe (Click #1) to the
back edge of the side panel (Click #2).

The central part of the counter is to be 1100 mm high. Since the side panel is to be perched
on the plinth, it is 980 mm high.

6 Press Ctrl+E to create an extrude with a height of 980 mm.

7 Make sure that the connection part is selected and press Ctrl+Alt+M to call 3D Move....
(You can also choose Modify > Move or select it from the contextual menu.)

8 Enter 120 mm in the Z Offset box.

9 Add a side panel to the right front scribe as well and make it 1080 mm high. It does not
have to be redoubled.

Click #1

Click #2

Make sure to select the inner edge of the fron scribe, NOT the inner edge of the plinth!
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The counter should now look like this:

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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2.2.6 Assign and Edit Texture

Finally, we assign textures to the scribes and side panels.

1 Select the outer scribes and the two side panels.

2 Select the texture Metal Aluminium 03 MAT from the Resource Browser and double-click
it.

3 Select the central scribe and assign the texture Oakwood 02 MAT to it in the same way.

4 Check the result using the render mode Custom Renderworks.

If required, the grain of the central scribe can be rotated.

1 Select the scribe and change to the Render tab in the Object Info palette.

2 Set Rotation to 90 degrees and press Enter to confirm.

The result should look like this:

3 Change back to Wireframe.
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2.2.7 Storage Trays

Now, we add storage trays onto the right and central sides of the counter. We first extract
the top inner edge from the right scribe and then create the desired board from it.

1 Select the Extract  tool and make sure that Extract Curve Mode is selected.

2 Click the top outer edge of the right front scribe and press Enter to confirm.

3 Press Ctrl+Alt+U to create a tapered extrude of 19 mm height from the NURBS curve.

4 Select the Shell Solid  tool.

5 Select Shell Solid Preferences . Set Thickness to 308 mm and Shell to Inside (!).

6 Click the tapered extrude you just created and press Enter to confirm.

7 Assign the texture Metal Aluminium 03 MAT to this storage tray.

We proceed in a similar fashion for the central storage tray. The difference is that this storage
tray is to protrude over the front scribe by 10 mm.
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1 First use the Extract  tool to extract the top outer edge of the central scribe as a
NURBS curve.

2 Then double-click the Offset  tool in the Basic palette.

3 Set the Distance to 10 mm.

4 Make sure that Offset Selected Objects is selected.

5 The original NURBS curve is not needed anymore, so you should select Offset Original
Objects. Click OK to confirm..
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6 We want to offset the curve to the outside. Click outside of the counter front panel as
shown below. (Referring to the screen, you have to click underneath the curve.)

7 Press Ctrl+Alt+U to create a tapered extrude with a height of 38 mm from the offset
curve.

8 The 228 mm width of the storage tray is created using the Shell Solid  tool. (Repeat
the previously described steps.)

The central storage tray should now look like this:
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2.3 Front Ledge

In the next step, we will create a ledge at the front of the central part. We first create an
extrude along path and then cut the individual boards from that extrude.

2.3.1 Create Path

For the path, we will extract the outer edge of the central scribe.

1 Select the Extract  tool and make sure to select Extract Curve Mode.

2 Click the bottom outer edge of the scribe and press Enter to confirm.
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2.3.2 Create Profile

In the next step, we will draw the profile for the extrude along path. The extrude is to have
the following dimensions:

Press Ctrl+5 to return to Top/Plan view. 

Now we use the 2D Polygon  tool to draw the three straight lines on an empty space in
the drawing as shown above.

1 Start at the bottom right (Click #1) and then draw a horizontal (Angle 0° or 180°) line
which is 60 mm long (Click #2).

2 From there, draw a vertical line (Angle 90°), 500 mm long (Click #3).

3 The third part is to run horizontally to the right (Angle 180°) and to be 300 mm long.
Double-click (!) here (Click #4).

Click #3
Double-click

Click #2 Click #1
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4 For the next step of the drawing, select the Arc  tool from the Basic palette.

5 Select Arc by 2 Points and a Specified Radius  on the Tool bar.

6 Place the first vertex of the arc at the bottom (Click #1), the second one at the top of the
polygon (Click #2).

7 Set the radius to 640 mm in the following dialog.

8 Select the polygon and the arc. Then choose Modify > Compose.

The individual objects are joined into one polyline.

2.3.3 Create Extrude along Path

1 Select the polyline and the NURBS curve extracted in chapter 2.3.1.

2 Press Ctrl+Alt+X. (You can also choose Model > Extrude Along Path.)

3 The NURBS-Curve (!) should be marked in red. Otherwise, click the Next or Prev buttons
to toggle between selections.

Click #2

Click #1
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4 Click OK to confirm.

5 Change to Left Isometric view.

The extrude along path is not yet at the right position: it is not at the right height, and it is
still inside the counter. To correct this, we edit the extrude and then move the profile to the
appropriate position relative to the path.

6 Double-click the extrude along path.

7 In the following dialog, select Edit Profile and click OK to confirm. 

The display changes. The profile and a dashed crosshairs are displayed.

8 Select the profile and set the insertion point to bottom left in the Object Info palette.

9 Now change the values for ±x and ±y to 0 in the Object Info palette.

10Click the orange Exit Profile button to exit the profile.l

9

98
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2.3.4 3D Contours

In the next step, we will cut the extrude into regular horizontal sections and create 19 mm
boards from these.

For more clarity, we will first group the extrude.

1 Select the extrude and press Ctrl+G.

2 Double-click the group to work inside it.

3 Change to Front view.

4 Select the Create Contours  tool from the 3D Modeling tool set.

The extrude is to be split into four sections.

5 Select Create Contours Preferences  in the Tool bar. Set the Contour Increment to
500/4 mm.

6 Move the mouse over the bottom right corner of the extrude and click when the cue Point
is displayed (Click #1).

7 Drag the cursor to the left and click on the bottom edge of the extrude (Click #2).

8 Change to Right Isometric view.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Click #2 Click #1
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The extrude is now criss-crossed by red curves running along its shape. The curves are
grouped by default.

Now we can assign a thickness to the surfaces.

9 Press Ctrl+U to ungroup the curves and call Tapered Extrude (Ctrl+Alt+U).

10Assign the surfaces a thickness of 19 mm. Make sure to set the Taper Angle to 0°.

11The original extrude is no longer needed. Select it and press DEL to delete it.

12Click the orange Exit Group button to exit the group.

The counter should now look like this:
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2.4 Work Surface

In this chapter, we will design the work surface of the counter.

2.4.1 Create Class

Before designing the basic geometry of the work surface, we create a class. Via this class, we
can later access all objects of the basic geometry.

1 Click Exit Group to return to the main drawing.

2 Press Ctrl+5 to return to Top/Plan view.

3 Right-click an empty space in the drawing and select Classes... from the contextual menu
click the Classes shortcut in the View bar.
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4 Click New in the following dialog.

5 Name the new class Work Surface.

6 Uncheck Edit Properties After Creation in case it is checked. All other options of this dialog
are unimportant.

We want to store the objects of the work surface’s basic geometry in the Work Surface class,
so we have to set it as the active class.

7 To do this, place the check in front of the class Work Surface in the list.

8 Click OK to confirm.
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2.4.2 Draw Contour Section

In this chapter, we will create the separate parts of the work surface contour in several short
steps. Afterwards, we combine it into a continuous surface.

1 Select the Arc  tool and select Arc by Radius Mode .

2 Start the arc at the 2D locus (Click #1).

3 Set the radius to 1230 mm in the L box.

4 Stretch the arc between the bottom edge of the column (Click #2) and the bottom part
of the right side panel (Click #3).

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Click #2

Click #3

Click #1
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The next section of the contours starts at the arc.

1 Select the 2D Polygon tool and start a polygon at the top left vertex of the arc (Click #1).

2 Move the cursor onto the top right corner of the column and then back to the right. Click
when the message 90° / Align 0° is displayed (Click #2).

3 Draw the next line from there to the top right corner of the column (Click #3) and
another line along the right edge of the column (Click #4).

4 The last line of the polygon ends at the inner edge of the front scribe. Double-click (!)
there to finish the polygon (Click #5).

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Click #4

Click #3

Click #2

Click #1

Double-click 5
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The basic form of the work surface adjoining the window is also first drawn as a polygon.

1 Start the polygon at the inner edge of the right front scribe (Click #1).

2 Draw the first two lines along the wall (Click #2, 3).

3 The third line starts at the inner corner of the wall and runs 600 mm upwards at an angle
of 90° (Enter value and Click #4).

4 Move the cursor in the direction of the arc and double-click when the cue Object / Hori-
zontal is displayed (Click #5).

For the front edge of the work surface, we trace the inner edges of the front scribes.

1 Select the Arc  tool and Three Points Mode.

Click #1

Click #3Click #2

Click #4

Click #4Double-click 5
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2 Trace the arc by clicking the beginning (Click #1), any place along the line (Click #2) and
the end (Click #3).

3 Repeat for the remaining two front scribes. Make sure to trace the inner edges of the
front scribes.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

Click #3

Click #2

Click #1
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2.4.3 Work Surface - Basic Shape

For further use, we group the contours created in the previous chapter and work inside this
group.

1 Choose Tool > Custom Selection... Make sure that Select Only and Execute Immediately
are selected. Then click Criteria to proceed.

2 Make all changes as shown below to select all objects that are in the class Work Surface
and click OK.

The Object Info palette shows that 6 Objects are selected.

3 Press Ctrl+G to group the objects.

4 Press X to change back to 2D Selection and double-click the group to work inside it.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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Now we complete the contour with the missing line elements.

1 Select the three arcs at the front and press Ctrl+B to send them to the back.

2 Select the Line  tool and connect the end vertices of the arcs.

The smallest arc, which was drawn first, protrudes to the right, so it has to be shortened.

3 Select the inner arc and press Ctrl+F to send it to the front.

4 Select the Trim  tool from the Basic palette.

5 Now click the end of the arc to be trimmed. Make sure to click the object edge, not the
arc’s surface.
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2.4.4 Connect Individual Objects and Create Work Surface

Now we will combine all objects into one surface. 

1 Press Ctrl+A to select all objects.

2 Choose Modify > Compose. 

The individual objects are composed into a polyline.

3 Press Ctrl+E to give the polyline an extrusion of 38 mm.

4 Press Ctrl+Alt+M and set the Z Offset to 730 mm.

5 Click Exit Group.

2.4.5 Cut the Work Surface

In the last step, two gaps for the connections have to be cut into the work surface. We copy
the side panels into the work surface group.

1 Double-click the front ledge to access the group containing the front scribes.

2 Change to Right Rear Isometric view.

3 Select the right and left side panels.

4 Press Ctrl+C to copy them to the clipboard.

5 Exit the group and double-click the edge of the work surface to access the other group.

6 Press Ctrl+Alt+V to paste the elements from the clipboard into the group. 

7 Press Ctrl+A to select the three objects.

The command Paste in Place (Ctrl+Alt+V) pastes the elements from the clipboard to the
same coordinates as the original elements.
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8 Choose Model > Subtract Solids.

9 Make sure that the work surface is marked in red.

10Click OK to confirm.

11Click Exit Group to return to the main drawing.

After finishing the work surface, we can now reset the active class to None. You can do this
either as described as in chapter 2.4.1 or via the pull-down menu on the View bar.

12Select None from the pull-down menu as active class.

13 If you have not already done so, you should press Ctrl+S now to save your drawing.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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3 Visualization

The counter design is now completed. The following part of the course deals with visualizing
the counter and creating effective presentations.

The end result of this chapter should look like this:

In this chapter, you will become acquainted with the following tools and features:

Pasting objects via the Resource Browser

Creating Sheet Layers

Creating Viewports

Inserting Renderworks Camera 

Using the Light Tool 

Converting objects to Line and Area Lights
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3.1 Add Props

Before visualizing our counter, we will add some props to the drawing: a chair, a screen, and
lamps.

3.1.1 Insert Chair

1 Press Ctrl+5 to change to Top/Plan view.

2 Make sure that the resources of the file Counter Design are displayed.

3 Double-click the symbol Chair Stoll 07 in the category Symbols/Plug-in Objects.

The contours of the chair are now displayed in extension lines around the cursor.

4 Insert the chair behind the counter as shown below. The first click defines the position, the
second one the orientation of the chair.
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3.1.2 Insert Screen

1 Double-click the object Screen 04 19" in the Resource Browser.

2 Insert the screen as shown below. 

3 Change to Left Isometric view.

4 Make sure the screen is selected.

5 Press Ctrl+Alt+M, enter 730+38 mm in the Z Offset box and click OK to confirm.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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3.2 Create Sheet Layer

In this chapter, we will arrange different views of our drawing on a sheet layer for printing. 

1 Right-click an empty space in the drawing and select Layers... from the contextual menu
or click the Layers shortcut in the View bar.

2 Change to the Sheet Layers tab and click New.

3 You can take over the default name, Sheet Layer-1.

4 Check Edit Properties After Creation and click OK to confirm.
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5 Enter 150 dots per inch in the DPI box.

6 Click Page Setup....

7 In the Page Setup dialog, adjust all settings as shown below and then click Printer Setup.

8 In the Printer Setup dialog, choose the desired printer and set paper size and orientation
to A4 and Portrait.

9 Click OK to confirm in all open dialogs to return to the main drawing.

The drawing now shows a blank page.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

5

6
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3.3 Create Viewports

3.3.1 Floor Plan View

The currently displayed (“active”) layer can be selected from a menu in the View bar.

1 Use the box to change back to Design Layer-1.

2 Right-click an empty space in the drawing and select Create Viewport... from the contex-
tual menu.

3 Set View to Top/Plan. Check the other settings as well.

Click OK to confirm. Vectorworks inserts the viewport on the sheet layer. 
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4 Move the viewport to the bottom left corner of the drawing.

5 Open the Layer menu on the View bar to return to Design Layer-1.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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3.3.2 Perspective View

Next, we want to insert a perspective view of the room into the sheet layer. In addition to the
command Set 3D View, you can also use the Renderworks Camera  tool to create
perspective view.

1 Press Ctrl+5 to change to Top/Plan.

2 Select the Renderworks Camera  from the Visualization tool set.

3 As shown below, click once to define the camera’s position (Click #1) and a second time
to define its orientation (Click #2).

4 In the pop-up dialog, change Camera Height to 1700 mm.

5 Look To Height should be 1300 mm.

6 Click OK to confirm.

Click #2

Click #1

4

5
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We assign the camera to one of the classes so we will later be able to hide it in the floor plan
view. 

7 Change the camera’s classes to Camera and Lights in the Object Info palette (!).

8 Click Display Camera View in the Object Info palette.

9 To place this view on the sheet layer, right-click an empty space in the drawing and select
Create Viewport... from the contextual menu.

10Change the Scale to 1:100 in the pop-up dialog.

11Set Rendering to Fast Renderworks.

12Click OK to confirm.

13Move the viewport to the top half of the page.

The viewport is not rendered immediately. It has to be updated first.

7

8

11

10
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14Select the viewport and click Update in the Object Info palette.

Now the rendering is displayed on the sheet layer. 
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3.3.3 Change Class Visibilities

All changes you make in the design layer als o show up in the viewports. Since the camera is
displayed in the floor plan view, we will now change the class visibilities to hide the camera
in this view.

1 Select the floor plan view.

2 Click Classes... in the Object Info palette.

3 Set Camera and Lights to Invisible and click OK to confirm.

You can now create more sheet layers and place viewports on them as described.

When you create viewports, make sure that the correct sheet layer is selected in the dialog.
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3.4 Lights

In the next step, we add lights to our drawing to make the rendering more realistic. Also, our
room is still without a ceiling.

3.4.1 Draw Ceiling

1 Open the Layer menu in the View bar and return to Design Layer-1.

2 Make sure that the drawing is displayed in Top/Plan (Ctrl+5) view.

3 Select the 2D Polygon  tool.

4 Select Polygon From Inner Boundary Mode in the Tool bar.

5 Click any empty space inside the room.

The room’s floor plan is created as a polygon.

6 Press X to exit the polygon tool.

7 Press Ctrl+E to convert the polygon to an extrude. Set the extrusion to 50 mm.

8 Press Ctrl+Alt+M (3D Move).
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9 Set Z Offset to 2500 mm. Make sure that X Offset and Y Offset are set to 0 and click OK
to confirm..

10Finally assign the texture Plaster 01 Mat to the ceiling via the Resource Browser.

3.4.2 Create Ceiling Element

In the next step, we create a ceiling element with lights above the counter.

The element consists of two slats (1) which are lit from behind by line light objects (2). Two
scribes (3) close off the space between the slats and up to the ceiling.

(1)

(1)

(3)

(3)

(2)

(2)
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The base of the ceiling element is the quarter of a circle between the column and the right
wall of the room.

1 Select the Arc  tool.

2 Make sure that Arc by Radius Mode is selected.

3 Click the 2D locus created in chapter 2.1.1 (Click #1) and draw an arc from the bottom
left corner of the column (Click #2) to the right wall (Click #3).

As in the chapters before, we use a group for more clarity.

1 Select the arc and press Ctrl+G.

2 Double-click the group to work inside it.

3 Press Ctrl+Alt+N to convert the arc to a NURBS curve.

Click #3

Click #2

Click #1
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The arc we just drew will become the front edge of the top slat. We need another arc for the
bottom slat.

1 Press Ctrl+C to copy the arc to the clipboard.

2 Press Ctrl+Alt+V to paste in the NURBS curve as congruent duplicate.

3 Subtract 100 mm from the Radius in the Object Info palette.

Now two arcs should be visible.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

100

We will need the arc in the clipboard later for the scribes between the slats and for the
line lights. Make sure to copy nothing else to the clipboard until the end of this chapter.
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In the next step, we create the two slats as shells and move them into the right position rela-
tive to each other.

1 Change to Right Isometric view.

2 Press Ctrl+Alt+U to create a tapered extrude from the outer arc. Set the extrusion to 25
mm. Make sure that the Taper Angle is set to 0°.

3 Select the Shell Solid  tool from the 3D Modeling tool set.

4 Select Shell Solid Preferences  on the Tool bar. Set Shell to Inside and Thickness to
400 mm.

5 Select the tapered extrude just created and press Enter to confirm.

6 Press Ctrl+Alt+M to move the wider slat upwards by 25+35 mm.

7 Repeat steps 2 through 5 for the other arc to create the smaller slat. Enter a Thickness of
300 mm in Shell Solid Preferences .

The result should look like this:

2
5
3
5
2
5

300

400
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Now we will create the two scribes in between as tapered extrudes and move them to the
right positions relative to each other.

1 Press Ctrl+Alt+V to paste another copy of the original arc in place.

2 Use the Object Info palette to subtract 75 mm from the radius of this curve.

3 Press Ctrl+Alt+U to create an extrude of 35 mm height.

4 Press Ctrl+Alt+M to move the scribe upwards by 25+35+25 mm.

5 Press Ctrl+Alt+V to paste in another copy of the arc and subtract 175 mm from the
radius.

6 Press Ctrl+Alt+U to create an extrude of 35 mm height.

7 Press Ctrl+Alt+M to move the scribe upwards by 25 mm.

The result should look like this:

In the last step, we assign textures to the objects.

1 Press Ctrl+A to select all objects within the group.

2 Select the texture Plaster 14 Mat from the Resource Browser and double-click the
objects to assign it to them.

3
5

3
5

175

75
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3.4.3 Create Line Lights

Line lights are created from two more copies of the arc.

1 Press Ctrl+Alt+V to paste another copy of the arc in place and subtract 50 mm from the
radius.

2 Press Ctrl+Alt+M to move this NURBS curve upwards by 25+35+25+5 mm.

3 Paste in the final copy of the arc and subtract 150 mm from the radius.

4 Move this NURBS curve upwards by 25+5 mm.

The result should look like this:

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

5

5

50

150
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In the next step we convert the arcs pasted and edited in the previous chapter to line lights.

1 Select one of the NURBS curves.

2 Choose Modify >Convert >Convert to Line Light....

3 In the Light Preferences dialog, change Brightness to 250 Lumens and click OK to confirm.

4 Repeat with the same settings for the other NURBS curve.

All parts of the ceiling element were created on the ground layer by default. Now we move
them upwards to the ceiling.

1 Press Ctrl+A to select all objects inside the group.

2 Press Ctrl+Alt+M to call 3D Move.... Move the objects by 2500-35-25-35-25 mm on the
Z axis to their final position beneath the ceiling.

3 Click Exit Group to return to the main drawing.
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3.4.4 Insert Directional Light

In the next step, we insert a directional light. This light is placed outside the room to simulate
the light coming in through the windows.

1 Press Ctrl+5 to change to Top/Plan view.

2 Select the Light Tool  from the Visualization tool set.

3 Select Directional Light on the Tool bar.

4 Place the directional light as shown below.
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5 In the pop-up dialog, set Brightness to 20 %.

6 Click Directional Light Specs....

7 Set Azimuth to 52 degrees and Elevation to 30 degrees.

8 Click OK to confirm in both dialogs.

9 Change the Z position of the light to 3000 mm in the Object Info palette.

10Press Ctrl+5 to return to Top/Plan view.

6

5

You can now look at the intermediate result. Select the Camera tool and click Display
Camera View in the Object Info palette. Then select Fast Renderworks with Shadows from
the View > Rendering and change back to Top/Plan view.
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3.4.5 Add Area Light

Even though there is directional light coming through the windows, the room still seems too
dark. In this part of the course, we will add two area lights to the left and the right area of
the room.

1 Select the Line  tool.

2 As shown below, draw a 2000 mm long line running parallel to the left wall.

3 Press Ctrl+E to create an extrude with a height of 1000 mm from the line.

4 Press Ctrl+Alt+M to move the extrude upwards by 900 mm.
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5 Choose Modify > Convert > Convert to Area Light...

6 In the pop-up dialog, set Brightness to 500 Lumens.

7 Make sure that Dimmer is set to 100%.

8 Click Area Light Specs....

9 Set Dist Falloff to None.

10Uncheck Render Geometry.

11Click OK to confirm both dialogs.

8

6

7

9

10
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The area is converted to an area light. A red arrow indicates in which direction the light falls.

12Make sure that the arrow points to the right. If this is not the case, click the button Flip
Direction in the Object Info palette. (You may have to scroll down in the palette to find it.) 

The red arrow and the modification points are only displayed if the 2D Selection tool
(shortcut X) is set to Single Object Interactive Scaling Mode .



Vectorworks interiorcad Advanced Course - 3D Design and Visualization76

The second area light is created in the same way.

1 As shown below, draw a 1500 mm long line running parallel to the right wall.

2 Press Ctrl+E to create an extrude of 1000 mm height from the line. Press Ctrl+Alt+M to
move the extrude upwards by 900 mm.

3 Choose Modify > Convert > Convert to Area Light... to convert the extrude to an area
light.

4 In the Light Preferences - Area Light dialog, set Brightness to 200 Lumens and Dist Falloff
to None.

5 Click OK to confirm.

6 Click Flip Direction in the Object Info palette to make sure that the red arrow points
towards the counter.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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3.4.6 Add Lamps

Next, we will add two lamps above the counter.

First we will create an arc to help us place the lamps.

1 Select the Arc  tool.

2 Make sure that Arc by Radius Mode is active.

3 Click the 2D locus drawn in chapter 2.1.1.

4 Press TAB to change to the L input box and enter 1400 mm.

5 Press TAB again, enter 180 degrees in the A box and press Enter to confirm.

6 Click into the drawing.

7 Drag the cursor down and to the right without clicking.

8 Press TAB again, set the Angle to 80 degrees and press Enter to confirm.

9 Click into the drawing again.
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Now the lamps can be placed.

1 Select the symbol DL Erco Domotec from the resource type Symbols/Plug-in Objects in the
Resource Browser and double-click it.

2 Move the mouse over the top vertex of the arc and double-click when the cue Endpoint
is displayed.

3 Change to Left view.

4 Make sure that the lamp symbol you just inserted is selected. In the Object Info palette,
set the Z value to 2500 mm.

5 Change the Light Brightness setting to 50% and press Enter to confirm.

6 Press Ctrl+5 to change to Top/Plan view.

4

5
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7 Select the arc and the lamp.

8 Choose Edit > Duplicate Along Path.

9 Adjust the settings in the pop-up dialog as shown below:

10Click OK to confirm.

11Double-click the arc (path).

12The arc and the first lamp can now be deleted.

13Select the lamp above the screen and change the Angle to -80 degrees in the Object Info
palette.

14Select the other lamp and set the angle to 150 degrees.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________
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3.4.7 Visible Light Beam

In the next step, we want to adjust the settings of both lamps so that their light beams
become visible.

1 Right-click the symbol DL Erco Domotec in the Resource Browser.

2 Select Edit... from the contextual menu.

3 In the following dialog, select 3D Component and click Edit to confirm..
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The symbol content is now displayed in the drawing.

4 Click one of the symbolic arrows to select the light.

5 Check Lit Fog in the Object Info palette.

6 Click the Exit Symbol button to exit the symbol.

Additionally, we have to assign a Renderworks Background so that the effect will be visible.

1 Change to the category Render Backgrounds in the Resource Browser.

2 Right-click the background named Background-1 and select Edit... from the contextual
menu.

3 Set Weather to Lit Fog and click Options....
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4 Set Max Density to 0.00002.

5 Adjust all other settings as shown below and click OK to confirm:

6 Double-click Background-1 in the Resource Browser to assign it to the drawing.

If desired, you can now look at the result using the camera. We recommend using the setting
Custom Renderworks.

Notes:

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

_________________________________________________________________________

4

The rendering takes longer than before because of the lights etc. How long a rendering
will take depends on CPU performance, quantity of main memory available, contents of the
selected drawing, and selected render mode. A newer computer should only take a few
minutes; an older computer can take much longer than that.
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3.5 Select Background Image

In the last step, we will add a background image to the drawing.

1 Right-click Background-1 in the Resource Browser and select Edit... from the contextual
menu.

2 Set Background to Image.

3 Select Import an Image File and click OK to confirm.

4 Change to the desktop and select Counter Design Background.jpg. (This file was unzipped
along with the template.)
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5 In the following dialogs, always click OK to confirm.

Vectorworks now puts this picture in the background during rendering and renders the draw-
ing over it.

You can now change to the sheet layer and update the rendering. 

1 Set the viewport’s render mode to Custom Renderworks or the highest-quality (but also
most performance-intensive) Final Quality Renderworks.

2 Backgrounds are assigned to viewports individually. Set RW Background for this viewport
to Background-1.

3 Click Update.

1

2

3
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